This project has moved and is read-only. For the latest updates, please go here.

Free CodeSmith 2.6 and Windows 8

Feb 16, 2013 at 12:55 AM
Free CodeSmith 2.6 needs .Net 1.1, which is not supported on Windows 8.
Any suggestions?
Feb 16, 2013 at 10:49 AM

I'm running Windows7-64 bits and Framework 1.1 isn't installed on my computer. I never missed it and it goes without saying that I run CslaGeneratorFork quit often. After a quick search, I found Framework 1.1 has compatibility issues on Windows7-64 bits. So the question is:

Did you try to run CslaGeneratorFork on Windows8?
Feb 16, 2013 at 1:03 PM
Yes, of course I tried ....
One gets a dialogue offering to install .Net 1.1 or 1.0. Clicking yes takes you to a webpage which redirects to 1.1 Redistributable.
Downloading dotnetx and running leads to a compatibility warning, and on investigation MS say 1.1 is Not supported on Win 8.
So that's as far as I went. I don't want to destabilize a brand new installation of Win 8.
Not supported could mean it would work fine but there are no security updates so putting my PC at risk, or not supported could mean it does not work and it will be a devil to remove afterward.

(I did try CodeSmith 6.5.3, but that's not working either)
Feb 16, 2013 at 1:23 PM
Edited Feb 16, 2013 at 7:38 PM

As you might have guessed, I'm not running Windows 8 and, at this time, I have no access to a Windows 8 system. So I didn't found this issue.

Reading your message I don't quite understand if the install process refuses to go on of if you chose not to install it.

I have no possibility to try the solution below:

How to install .NET 1.1 framework in windows 8?

I would be most grateful if you care to try it and report back.

Concerning CodeSmith 6.5.3, as far as I know it doesn't use FX 1.1. and it should run on Windows 8.

Feb 18, 2013 at 12:48 AM
Thanks for finding that url. I'd not found it by my searches.
I did follow the instructions, and they worked once I ran CMD as administrator (in spite of UAC off).
Codesmith.exe then runs so long as you choose No to the cst association (unhandled exception if you do). Check for updates don't work either!
But I've not tried generating anything yet...

Lucky so far for a program so old.....
Always thought that you were taking a risk investing so much time where the only means of execution was version 2.6.0

I'll report back later.

PS when I said that 6.5.3 didn't work I meant for other reasons. Meaning that I'd got no way of generating any CSLA code!

When will you support CSLA 4.5?
Feb 18, 2013 at 7:38 AM
Edited Feb 18, 2013 at 7:39 AM

I'm afraid I didn't understand your exact problem. I thought you were having problems when CslaGenFork was using CodeSmith, i.e. when it generates files.
In order to run CslaGenFork you don't have to install CodeSmith. The CodeSmith procedure is as follows:

1) download the and just put it somewhere (like Desktop)
2) Open CslaGenFork
3) Go to Tools => CodeSmith Extension...

A popup window opens...

4) Click Install button
5) Select the file
6) Click Exit to close the popup

That's it. CslaGenFork unzips for you and copy the relevant files to the proper location.

Concerning CSLA 4.5 generation, I'm closing a CslaGenFork 4.3 release. After that I'll start work on CSLA 4.5 generation. This isn't as easy as it sounds since there are several different ways to use CSLA 4.5. But if you aren't generating Silverlight code, you can use the code - as it is generated today - on CSLA 4.5.

Tiago Freitas Leal
Feb 18, 2013 at 11:44 AM
Hi, I'm sorry I'd completely forgotten that...
As you've guessed I'm setting up my new Window 8 laptop, and when coming to this project's home page went looking for a 4.3 RC download, and got digressed into thinking would it still work; do I have the prerequisites, etc.
I've loaded 4.0.3 now and removed .Net 1.1, and it generates OK. So I guess .Net 1.1 is only used for the old 2.6 UI. Never knew that!
I guess CslaGenFork just uses the codegeneration DLL(s)
Sorry about that. Thanks for your time writing up the above.

Meanwhile, are there any 4.0.3 sample XML file(s). Was looking for the Invoice Sample, but there's only Database sql to download.

Thanks for the 4.5 tip. Yes, I'm WPF, so I'll look forward to 4.3 soon.