This project has moved and is read-only. For the latest updates, please go here.

Pls add mentioned info in FAQ

Oct 12, 2010 at 10:28 AM
Edited Oct 12, 2010 at 10:29 AM

Tried your faq and when i tried to add template as well as codesmith engine, it throwed a run time error that access is denied..

Tried it on Win 7 Ultimate with VS 2010 Prof.. Workaround is to run the program in administrator mode i.e. right click the program in c:\program files.... and choose run as administrator to run the prog.

Oct 14, 2010 at 10:41 PM

Hi vinodonly,

I'm lloking forward to have a test of your report but I'm running XP Pro. I don't have a Win7 VM and ask a co-worker to try it but...

The problem shows up exactly when?

1) Running the MSI installer?

2) Adding CodeSmith DLL?

3) Setting the template folder location?



Oct 16, 2010 at 8:16 AM
Problem happens/Runtime error is thrown on point 2 and 3 (after the product
is installed and we try doing these points)

2) Adding CodeSmith DLL?

3) Setting the template folder location?

Vista and Win7 are having somewhat similar protection as far as file access
is concerned. I tried it on win 7 but I'm sure that it will give same
problem on vista also.

Oct 17, 2010 at 1:00 AM

Hi Vinod,

It looks more like an issue than a FAQ entry,,,

2) Adding CodeSmith DLL?
This put some files in Application.StartupPath.

3) Setting the template folder location?
All it does is changing CslaGenerator.exe.config that is located in Application.StartupPath

A new question. can you please try to change the project defaults?

  1. open a new project
  2. change some settings in Project Properties
  3. click "Set Default"

This should report the same error as it changes Default.xml that is also located in Application.StartupPath


Oct 17, 2010 at 8:16 AM
You are correct. An error is thrown/messagebox is shown when a new project
is created and same way the same error comes when I click on set default..

This is known as elevated rights, where whenever a application try to access
such type of resources then they need admin rights..

Either the code should be changed to avoid that or users should be informed
that this is an issue.

Oct 17, 2010 at 4:55 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Oct 17, 2010 at 4:57 PM

Hi Vinod,

I intend to solve the issue. Any suggestions?



Oct 18, 2010 at 8:35 AM
I have few apps running on different os but not getting error like this

The reason I could think of is that code is trying to write to some system
reserved directory and that is why it is blocking and need admin rights..

If we simply change the code to write to a normal dir i.e. the one which is
not system reserved then err will go.

In my other apps, I have tried writing settings or other temporary files in
c:\temp or c:\windows\temp and it works without any issues, we can do the
same for this..

Thanks n Regards,
Oct 18, 2010 at 8:47 AM