This project has moved and is read-only. For the latest updates, please go here.

CLSAGenFork crashing

Aug 9, 2011 at 10:29 PM

I installed the 01.08.2011 release, and it worked (Although I made mistakes).
In view of your comments on the home page, I downloaded the latest and build it. I changed various strings to update to 2011.08.07 etc, and build the setup.
Installed the setup, which removed 2011.08.01 and tried to run 2011.08.07. As soon as I try to change the project directory, the app crashes.
It fails because  _controller.CurrentUnit is null

        private void ProjectPanelTargetDirChanged(string path)
            _controller.CurrentUnit.TargetDirectory = path;

System.NullReferenceException: Object reference not set to an instance of an object.
   at CslaGenerator.MainForm.ProjectPanelTargetDirChanged(String path)
   at CslaGenerator.Controls.ProjectPanel.OnTargetDirChanged(String newDir)

Even if I roll back, now 2011.08.01 crashes with same error.

Any suggestions?

Aug 9, 2011 at 10:34 PM

OK, I see what I was doing wrong. I need to press New first before trying the change the Output Directory.
I think that's a rather minor bug - they should be greyed out until after pressing new or opening a previous project.

Aug 9, 2011 at 10:35 PM

You are right:

ISSUE: If you try to change the Output Directory of the project before creating or loading a project CGF crashes.

FIX: Disable that button when there is no project present.

WORKAROUND: first create a new project; tthen change the output directory of the project.



Aug 9, 2011 at 10:36 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.